How to play Darkcraft Forgotten Worlds!

Demeris

Lord of the Pants
Ok so you wanna play Darkcraft: Forgotten Worlds but don't know how to get it? Here's a tutorial how...

1. Get the technic client:
First thing your going to need to do is download the Technic client from technicpack.net. goto http://www.technicpack.net/download and follow the instructions to get it.

2. Open the client and download the darkcraft unleashed modpack:
The technic client doesn't come with the modpack. Nor are we allowed to distribute it as such. So your going to have to download the modpack yourself. This is super easy. Just open the client. click on the "MODPACKS" tab at the top. On the left you will see popular modpacks that are distributed with the launcher. Ours is not a public pack so you have to search for it. At the top of the list of modpacks is a search bar. Type in "Darkcraft: Forgotten Worlds" and the list will change.


The list should go down to just our pack but it might show all packs with darkcraft in it. If it does this just pick the one titled "DarkCraft: Forgotten Worlds" and click "Install" in the lower right corner. Once installed It will change to a Play button.

After it's done just click the play button on the lower right of the main window and it will load the mod pack up. TAKE NOTE: This may take a while and might even appear as though the client has crashed. It may even say "The Client has Stopped Responding" on the top. This is normal. The Modern Forge Loading screen has an anvil and hammer icon that should move along with progress bars to let you know everything is fine. Just give it some time and it WILL come to the standard minecraft start screen. Remeber its loading over 80 mods.

In Multiplayer, if the server is not already listed then simply add a new one and put in:
darkcraft.org:25557

it should show the server ping bars and how many on.. then as per normal. just click in and prepare for spawn! You may fall through the world for a bit as your client catches up with the server. This is normal. Just wait it out. No matter how far you fall you shouldn't fall out of the world and will appear on the spawn platform.

Keep in mind if your computer is a slower one it may not be completely agreeable with the pack. If the gamepack runs really slow you might be able to accelerate it with optifine. Generally we recommend this anyway. Due to license rules we can't include it directly in the pack but here is a link. Select the version for 1.7.10, simply go to the modpack folder(located in your .appdata/.technic/modpacks/darkcraft-forgotten worlds folder) and place optifine in the "mods" folder in there.

https://optifine.net/downloads

First things to troubleshoot if it wont load:

If the pack doesn't load go to the modpack folder again and go to "crash-reports". Select the most recent. If the first few lines say "out of memory" then go to the Modpack Options button in the upper right of the launcher and go to the Java tab. Increase the allocated ram to 2GB.

If its crashing for other reasons or it will not let you allocate more ram, check your java version and make sure you are using the latest version for your system. This includes making sure if your system is 64 bit that the version of Java is also 64 bit.
 
Last edited:

Micahdebick

Member
Hey, I followed your instructions to the letter, but when I press play it scrambles through all the "verifying.." crap, then the Technic Launcher closes, and another JAVA icon pops up in my app tray, then disappears and the Launcher comes back up.
What am I doing wrong??
Im using a Mac Mini.
Thanks,
Micah
 

Demeris

Lord of the Pants
I'm not 100% on macs but rarely this problem does occur on the PC. Every time I've had it happen, simply restarting the computer seems to fix it right up.
 

Demeris

Lord of the Pants
we need more information on the problem. Are you on PC or Mac? is it the Technic client not launching or is it locking up while loading the pack?
 

akiosh

Member
I have windows, and it is trying to load the pack. Technic client will lose like it is loading the modpack and then just re-open.
 

Demeris

Lord of the Pants
that means the modpack is crashing on your system for some reason. Try going to the modpacks folder and deleting it entirely then re-install it. The folder should be located in your user directory under <user>/appdata/roaming/.technic/modpacks/darkcraft-unleashed

just delete the darkcraft-unleashed directory then reload the launcher and try again. If this doesn't work then I'll need the crash report it generated. it will be in that darkcraft-unleashed folder under /crash-reports and will be the most recently dated file. I don't need the whole file just copy/paste like the first 25 lines into the forums.
 

akiosh

Member
2014-11-08 00:04:38 [INFO] [ForgeModLoader] Forge Mod Loader version 6.4.49.965 for Minecraft 1.6.4 loading
2014-11-08 00:04:38 [INFO] [ForgeModLoader] Java is Java HotSpot(TM) Client VM, version 1.8.0_25, running on Windows 7:x86:6.1, installed at C:\Program Files (x86)\Java\jre1.8.0_25
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Java classpath at launch is C:\Users\Tyler\AppData\Roaming\.technic\cache\net\minecraft\launchwrapper\1.8\launchwrapper-1.8.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\ow2\asm\asm-all\4.1\asm-all-4.1.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\scala-lang\scala-library\2.10.2\scala-library-2.10.2.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\scala-lang\scala-compiler\2.10.2\scala-compiler-2.10.2.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\lzma\lzma\0.0.1\lzma-0.0.1.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\net\sf\jopt-simple\jopt-simple\4.5\jopt-simple-4.5.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\argo\argo\2.25_fixed\argo-2.25_fixed.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\bouncycastle\bcprov-jdk15on\1.47\bcprov-jdk15on-1.47.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\google\guava\guava\14.0\guava-14.0.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\apache\commons\commons-lang3\3.1\commons-lang3-3.1.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\com\google\code\gson\gson\2.2.2\gson-2.2.2.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\lwjgl\lwjgl\lwjgl\2.9.0\lwjgl-2.9.0.jar;C:\Users\Tyler\AppData\Roaming\.technic\cache\org\lwjgl\lwjgl\lwjgl_util\2.9.0\lwjgl_util-2.9.0.jar;C:\Users\Tyler\AppData\Roaming\.technic\modpacks\darkcraft-unleashed\bin\modpack.jar;C:\Users\Tyler\AppData\Roaming\.technic\modpacks\darkcraft-unleashed\bin\minecraft.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Java library path at launch is C:\Users\Tyler\AppData\Roaming\.technic\modpacks\darkcraft-unleashed\bin\natives
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enabling runtime deobfuscation
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class FMLCorePlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod FMLCorePlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class FMLForgePlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod FMLForgePlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] All fundamental core mods are successfully located
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Discovering coremods
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy CodeChickenLib-universal-1.6.4-1.0.0.62.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in CodeChickenLib-universal-1.6.4-1.0.0.62.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy ForgeMultipart-universal-1.6.4-1.0.1.268.jar
2014-11-08 00:04:38 [FINEST] [ForgeModLoader] Found FMLCorePluginContainsFMLMod marker in ForgeMultipart-universal-1.6.4-1.0.1.268.jar, it will be examined later for regular @Mod instances
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class DepLoader
2014-11-08 00:04:38 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod DepLoader
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy appeng-rv14-finale3-mc16x.jar
2014-11-08 00:04:38 [FINEST] [ForgeModLoader] Found FMLCorePluginContainsFMLMod marker in appeng-rv14-finale3-mc16x.jar, it will be examined later for regular @Mod instances
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class AppEngCore
2014-11-08 00:04:38 [WARNING] [ForgeModLoader] The coremod appeng.transformer.AppEngCore does not have a MCVersion annotation, it may cause issues with this version of Minecraft
2014-11-08 00:04:38 [INFO] [ForgeModLoader] [AppEng] Core Init
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod AppEngCore
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy Artifice-1.1.3-243.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in Artifice-1.1.3-243.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy autoutils-1.6.4-1.0.1.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy backpack-1.28.37-1.6.x.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in backpack-1.28.37-1.6.x.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy BigReactors-0.3.4A2.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in BigReactors-0.3.4A2.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy Calclavia Core-1.1.1.131.jar
2014-11-08 00:04:38 [FINEST] [ForgeModLoader] Found FMLCorePluginContainsFMLMod marker in Calclavia Core-1.1.1.131.jar, it will be examined later for regular @Mod instances
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class CalclaviaPluginLoader
2014-11-08 00:04:38 [WARNING] [ForgeModLoader] The coremod calclavia.lib.CalclaviaPluginLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod CalclaviaPluginLoader
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy chisel-1.6.4-1.5.0fix.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy CodeChickenCore 0.9.0.9.jar
2014-11-08 00:04:38 [FINEST] [ForgeModLoader] Adding CodeChickenCore 0.9.0.9.jar to the list of known coremods, it will not be examined again
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class CodeChickenCorePlugin
2014-11-08 00:04:38 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
2014-11-08 00:04:38 [INFO] [STDERR] Warning: version of ForgeMultipart-universal-1.6.4-, 1.0.1.268 is newer than request 1.0.0.244
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod CodeChickenCorePlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy CoFHCore-2.0.0.5.jar
2014-11-08 00:04:38 [FINEST] [ForgeModLoader] Found FMLCorePluginContainsFMLMod marker in CoFHCore-2.0.0.5.jar, it will be examined later for regular @Mod instances
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Instantiating coremod class LoadingPlugin
2014-11-08 00:04:38 [WARNING] [ForgeModLoader] The coremod cofh.asm.LoadingPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Enqueued coremod LoadingPlugin
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy ComputerCraft1.63.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in ComputerCraft1.63.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy dimensional-anchor-57.1.96.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy EquivalentExchange3-1.6.4-0.1.142.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in EquivalentExchange3-1.6.4-0.1.142.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy ExtrabiomesXL-universal-1.6.4-3.15.8.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in ExtrabiomesXL-universal-1.6.4-3.15.8.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Examining for coremod candidacy ExtraCells-1.6.9e.jar
2014-11-08 00:04:38 [FINE] [ForgeModLoader] Not found coremod data in ExtraCells-1.6.9e.jar
 

HellsWarlord77

Moderator
Hey Dem,
Trying to log into darkcraft unleashed, and Im getting a "Connection lost Failed to login: bad login" notification on my screen. Help?
 

Demeris

Lord of the Pants
Hey Dem,
Trying to log into darkcraft unleashed, and Im getting a "Connection lost Failed to login: bad login" notification on my screen. Help?

Bad login 'usually' means you connected to somewhere else using another client while the one you are now using was open.

Example: You open up the technic launcher and get into unleashed. Then decide you wanna see what's going on in vanilla so you open up the Vanilla client and get on Darkcraft survival. But while your doing that you get the boot from Unleashed for being idle for 30 minutes. When you try to log back in you get "Bad Login" because the last client to access the Mojang login servers was the vanilla one, so the authentication servers 'think' you are not the right person logging into technic.

The usual fix for this is to close the entire technic launcher, then re-open it, click 'play' on the pack again and then log into unleashed. If it still gives you trouble I'll look at the logs and see what it's complaining about.
 
Hey,

So I just tried to get Technic, but after all the verifying is done, the launcher (I think that's what it is) closes but then opens again. I didn't see the regular Minecraft launcher either... help?

I am using a PC with windows...

Thanks,
q
 

Demeris

Lord of the Pants
Hey,

So I just tried to get Technic, but after all the verifying is done, the launcher (I think that's what it is) closes but then opens again. I didn't see the regular Minecraft launcher either... help?

I am using a PC with windows...

Thanks,
q
This problem has been cropping up a lot. It usually stems from a java issue with the latest java. If you have java 1.8.0_20 or higher there is an error that occurs with technic that can't be stopped except to downgrade your java. You need to replace your current java with either 1.8.0_11 or 1.7.0_67 as either of those "should" work to fix the problem. The technic thread on the matter: http://www.technicpack.net/article/view/concurrentmodificationexception-in-java-18020.89 says that 1.7.0_67 definitely works and 1.8.0_11 should work.
 

Garrettks34

Member
This problem has been cropping up a lot. It usually stems from a java issue with the latest java. If you have java 1.8.0_20 or higher there is an error that occurs with technic that can't be stopped except to downgrade your java. You need to replace your current java with either 1.8.0_11 or 1.7.0_67 as either of those "should" work to fix the problem. The technic thread on the matter: http://www.technicpack.net/article/view/concurrentmodificationexception-in-java-18020.89 says that 1.7.0_67 definitely works and 1.8.0_11 should work.
I'm not finding those downloads. Link pls?
 
Top